<!DOCTYPE html>
<html lang="en" xml:lang="en">
  <head>
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0"/>
    <meta property="article:published_time" content="2019-08-24Z10:03:00.0000000+01:00"/>
    <meta property="article:tag" content="Other Sport"/>
    <link rel="canonical" href="https://www.suffolkfreepress.co.uk/sport/blackmore-survives-late-crash-to-win-eastern-road-race-event-9080421/"/>
    <meta name="original-source" content="https://www.suffolkfreepress.co.uk/sport/blackmore-survives-late-crash-to-win-eastern-road-race-event-9080421/"/>
    <meta property="og:url" content="https://www.suffolkfreepress.co.uk/sport/blackmore-survives-late-crash-to-win-eastern-road-race-event-9080421/"/>
    <meta name="description" content="Nathan Blackmore survived a last lap crash on the Bulmer course on Sunday to take Eastern Road Race League honours by nine seconds."/>
    <meta name="keywords" content="Other Sport"/>
    <meta property="og:locale" content="en_GB"/>
    <meta property="og:description" content="Nathan Blackmore survived a last lap crash on the Bulmer course on Sunday to take Eastern Road Race League honours by nine seconds."/>
    <meta property="og:title" content="Blackmore survives late crash to win Eastern Road Race event"/>
    <meta property="og:type" content="article"/>
    <meta property="og:site_name" content="Suffolk Free Press"/>
    <script type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "articleSection": "Sport",
        "headline": "Blackmore survives late crash to win Eastern Road Race event\r",
        "keywords": [
          "Other Sport"
        ],
        "thumbnailUrl": "https://www.suffolkfreepress.co.uk/_media/img/WWBNUHTMNHKJNOB4YGJW.jpg",
        "author": {
          "@type": "Person",
          "name": "Sport Sudbury"
        },
        "creator": {
          "@type": "Person",
          "name": "Sport Sudbury"
        },
        "publisher": {
          "@type": "Organization",
          "logo": {
            "@type": "ImageObject",
            "url": "https://www.suffolkfreepress.co.uk/site-logo.png"
          },
          "name": "Suffolk Free Press"
        },
        "dateCreated": "2019-08-22T10:05:48.74248Z",
        "dateModified": "2019-08-22T10:05:48.74248Z",
        "datePublished": "2019-08-24T10:03:00Z",
        "image": "https://www.suffolkfreepress.co.uk/_media/img/WWBNUHTMNHKJNOB4YGJW.jpg",
        "mainEntityOfPage": {
          "@type": "WebPage",
          "@id": "https://www.suffolkfreepress.co.uk/sport/blackmore-survives-late-crash-to-win-eastern-road-race-event-9080421/"
        },
        "url": "https://www.suffolkfreepress.co.uk/sport/blackmore-survives-late-crash-to-win-eastern-road-race-event-9080421/"
      }
    </script>
    <meta property="og:image" content="https://www.suffolkfreepress.co.uk/_media/img/WWBNUHTMNHKJNOB4YGJW.jpg"/>
    <meta property="og:image:width" content="1571"/>
    <meta property="og:image:height" content="1080"/>
    <title>Nathan Blackmore comes out on top in Cycle Club Sudbury&#39;s Len Finch Memorial race</title>
    <script type="text/javascript" src="/_bundles/iliffe-base-v5057867.js"></script>
    <link type="text/css" rel="stylesheet" href="/_resources/iliffe_gallery_carousel-v4934161.css"/>
    <link type="text/css" rel="stylesheet" href="/_resources/iliffe-sfp-v5068073.css"/>
    <link type="text/css" rel="stylesheet" href="/_resources/WeatherIcons-v4482099.css"/>
    <script type="text/javascript" src="/_resources/common-v5050692.js"></script>
    <script type="text/javascript" src="https://cdn.conversant.mgr.consensu.org/gdpr/cmp/config/s/u/suffolkfreepress.co.uk/config.js"></script>
    <script type="text/javascript" src="/_resources/iliffe_gallery_carousel-v4934147.js" defer></script>
    <script type="text/javascript" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
    <script type="text/javascript" src="/_resources/smarttag-v4371176.js"></script>
    <script type="text/javascript" src="https://platform.twitter.com/widgets.js" async></script>
    <script type="text/javascript" src="https://secure-cdn.mplxtms.com/gdpr/cmp/gdpr-cmp-bootstrap.js"></script>
    <script type="text/javascript" src="https://cdn.mediavoice.com/nativeads/script/klmedia/km_master.js" async></script>
    <link rel="shortcut icon" type="image/x-icon" href="/favicon.ico" />
    <link rel="apple-touch-icon-precomposed" sizes="152x152" href="/apple-touch-icon-152x152-precomposed.png">
    <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/apple-touch-icon-144x144-precomposed.png">
    <link rel="apple-touch-icon-precomposed" sizes="120x120" href="/apple-touch-icon-120x120-precomposed.png">
    <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/apple-touch-icon-114x114-precomposed.png">
    <link rel="apple-touch-icon-precomposed" sizes="76x76" href="/apple-touch-icon-76x76-precomposed.png">
    <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/apple-touch-icon-72x72-precomposed.png">
    <link rel="apple-touch-icon-precomposed" href="/apple-touch-icon-precomposed.png">
    <script type="text/javascript">
      var pluginsConfig = {
        "Cmp" : true,
        "Comscore" : {
          "C1" : "2",
          "C2" : "6035892"
        },
        "Lotame" : {
          "Code" : "12965"
        },
        "Piano" : {
          "Code" : "HoLjsa7KTm"
        },
        "Taboola" : {
          "Url" : "https://cdn.taboola.com/libtrc/mediaforceeurope-network/loader.js"
        }
      };
    </script>
    <script>
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
      ga('create', 'UA-117685783-1', 'auto');
      ga('send', 'pageview');
    </script>
    <script type="text/javascript">
      var dfpConfig = { DesktopUnit: "~154725070~suffolkfreepress_desktop~sport", MobileUnit: "~154725070~suffolkfreepress_mobile~sport" };
    </script>
  </head>
  <body class="responsive">
<header id="header"> <div id="headerSearch"> <form class="search s top" method="get" action="/search/"> <div class="row"> <div class="offset-lg-3 col-lg-6"> <input class="typesearch sb" type="text" name="q" placeholder="What would you like to find?"/> <button type="submit" class="sbtn"><i class="fas fa-search fa-2x"></i></button> </div> </div> </form> </div><div class="mobilemenu d-lg-none"> <div class="row no-gutters mobilemenu navbar"> <div class="col-2 account"><div> <a href="/_api/transfer/transfer/login" rel="nofollow"> <span class="LoginFirst">Sign in&nbsp;&nbsp;</span><span class="usericon"><i class="fas fa-user-circle"></i></span> </a> </div></div> <div class="col-6 col-sm-4"> <a class="navbar-brand m-0 p-0" href="/"> <img src="/_assets/suffolkpress.svg" class="img-fluid" alt="Suffolk Free Press"/></a> </div> <div class="col-1 searchmob"> <div id="dropmobile"><a class="btn-search droptoggle" data-toggle="collapse"><i class="fas fa-search"></i></a> </div> </div> <div class="col-2 white text-center"> <button type="button" class="navbar-toggler w-100" data-toggle="collapse" data-target=".navbar-collapseMobile">&#x2630;</button> </div> </div> <div class="collapse navbar-collapseMobile" id="navbarSupportedContentMobile"> <div> <div class="topmenu"> <div class="text-center mobilenumber"> <i class="fas fa-phone fa-flip-horizontal"></i> <a href="tel:01787-886908">01787 886 908</a> </div> <div class="whitethindiv"></div> <ul class="nav navbar-nav"> <li><a href="http://www.photos.iliffemedia.co.uk" target="_blank">Photo sales</a></li> <li>|</li> <li><a href="http://iliffemedia.co.uk" target="_blank">Iliffe Media</a></li> <li>|</li> <li><a href="/announcements/">Announcements</a></li> <li>|</li> <li><a href="https://www.destinationeastanglia.co.uk" target="_blank">Destination East Anglia</a></li> <li>|</li> <li><a href="https://property.suffolkfreepress.co.uk/" target="_blank">Homes</a></li> <li>|</li> <li><a href="http://suffolk.yourlocalnotices.com/" target="_blank">Public Notices</a></li> <li>|</li> <li><a href="/advertise-with-us/">Advertise</a></li> <li>|</li> <li><a href="/_assets/iliffe-media-pack-aug19.pdf" target="_blank">Media Info</a></li> <li>|</li> <li><a href="/contact-us/">Contact us</a></li> <li>|</li> <li><a href="https://twitter.com/SFPSudbury" target="_blank"><i class="fab fa-twitter"></i></a></li> <li>|</li> <li><a href="https://en-gb.facebook.com/SuffolkFreePress/" target="_blank"><i class="fab fa-facebook-f"></i></a></li> </ul> </div> <div class="clearfix"></div> <div class="row no-gutters mobweather pb-2"> <div class="mx-auto text-left width"><a href="/weather/"> <i class="wi wi-day-sunny float-left" alt="Mainly Fair "></i> <div class="WeatherHomeInfo"> <span class="Temp">28&deg;</span><span class="TempLater"> | 10&deg; - 5 days <i class="fa fa-angle-right" aria-hidden="true"></i></span> </div> </a></div> </div> <ul class="p-2 dropnav"><li><span><a href="/">Home</a></span></li> <li class="menuParent"> <span>News <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/news/">News</a></li> <li><a href="/news/business/">Business</a></li> <li><a href="/news/crime/">Crime</a></li> <li><a href="/news/education/">Education</a></li> <li><a href="/news/environment/">Environment</a></li> <li><a href="/news/health/">Health</a></li> <li><a href="/news/offbeat/">Offbeat</a></li> <li><a href="/news/politics/">Politics</a></li> <li><a href="/news/transport/">Transport</a></li> <li><a href="/news/your-say/">Your Say</a></li> <li><a href="/news/in-full/">In Full</a></li> <li><a href="http://edition.pagesuite-professional.co.uk/Launch.aspx?PBID=d376981d-732d-4761-8f60-3b1e2b067bfe" target="_blank">E-edition</a></li> </ul> </div> </li> <li class="menuParent"> <span>Sport <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/sport/">Sport</a></li> <li><a href="/sport/cricket/">Cricket</a></li> <li><a href="/sport/football/">Football</a></li> <li><a href="/sport/more-sport/">More Sport</a></li> <li><a href="/sport/in-full/">In Full</a></li> </ul> </div> </li> <li class="menuParent"> <span>Lifestyle <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/lifestyle/">Lifestyle</a></li> </ul> </div> </li> <li class="menuParent"> <span>What's On <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/whats-on/">What's On</a></li> <li><a href="/whats-on/arts/">Arts and Screen</a></li> <li><a href="/whats-on/music/">Music</a></li> <li><a href="/whats-on/theatre-and-comedy/">Theatre and Comedy</a></li> <li><a href="/whats-on/in-full/">In Full</a></li> </ul> </div> </li> <li class="menuParent"> <span>Jobs <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="https://www.imjobs.co.uk/" target="_blank">Jobs</a></li> </ul> </div> </li> <li class="menuParent"> <span>Contact <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/contact-us/">Contact</a></li> </ul> </div> </li> <li class="menuParent"> <span>Velvet Mag <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="https://www.velvetmag.co.uk/" target="_blank">Velvet Mag</a></li> </ul> </div> </li></ul> </div> </div> </div><div class="desktopmenu d-none d-lg-block"> <nav class="navbar navbar-expand-lg navbar-light top" id="menu"> <div class="container"> <div class="row no-gutters w-100"> <div class="col-lg-11"> <div class="FirstMenu"> <ul class="nav navbar-nav"> <li><a href="http://www.photos.iliffemedia.co.uk" target="_blank">Photo sales</a></li> <li>|</li> <li><a href="http://iliffemedia.co.uk" target="_blank">Iliffe Media</a></li> <li>|</li> <li><a href="https://www.destinationeastanglia.co.uk" target="_blank">Destination East Anglia</a></li> <li>|</li> <li><a href="/announcements/" target="_blank">Announcements</a></li> <li>|</li> <li><a href="http://suffolk.yourlocalnotices.com/" target="_blank">Public Notices</a></li> <li>|</li> <li><a href="https://property.suffolkfreepress.co.uk/" target="_blank">Homes</a></li> <li>|</li> <li><a href="http://edition.pagesuite-professional.co.uk/Launch.aspx?PBID=d376981d-732d-4761-8f60-3b1e2b067bfe" target="_blank">E-edition</a></li> <li>|</li> <li><a href="/_assets/iliffe-media-pack-aug19.pdf" target="_blank">Media Info</a></li> <li>|</li> <li><a href="/advertise-with-us/">Advertise</a></li> </ul> </div> </div> <div class="col-lg-1 text-right socialsearch"> <ul> <li><a href="https://twitter.com/SFPSudbury" target="_blank"><i class="fab fa-twitter"></i></a></li> <li><a href="https://en-gb.facebook.com/SuffolkFreePress/" target="_blank"><i class="fab fa-facebook-f"></i></a></li> <li class="d-none d-sm-block"> <div id="drop"><a class="btn-search droptoggle"><i class="fas fa-search"></i></a></div> </li> </ul> </div> </div> </div> </nav> <div class="LogoSection"> <div class="container"> <a href="/"> <img src="/_assets/suffolkpress.svg" alt="Suffolk Press" class="main-logo"/></a> <div class="WeatherHome float-right d-none d-sm-none d-lg-block"><a href="/weather/"> <i class="wi wi-day-sunny float-left" alt="Mainly Fair "></i> <div class="WeatherHomeInfo"> <span class="Temp">28&deg;</span><span class="TempLater">| 10&deg;</span> <div class="clearfix" style="height: 1px;"></div> <span class="FiveDays" style="">5 days <i class="fa fa-angle-right" aria-hidden="true"></i></span> </div> </a></div> </div> </div> <div class="DesktopMenuBar"> <div class="container"> <div class="row no-gutters"> <div class="col-auto mr-auto"> <div class="LeftMenu"> <div class="nav navbar-nav dropdown mmenu"> <ul><li><span><a href="/">Home</a></span></li> <li class="Parent nav-item dropdown"> <span><a href="/news/">News</a></span> <div class="menuChildren dropdown-menu-d"><ul> <li><a href="/news/business/">Business</a></li> <li><a href="/news/crime/">Crime</a></li> <li><a href="/news/education/">Education</a></li> <li><a href="/news/environment/">Environment</a></li> <li><a href="/news/health/">Health</a></li> <li><a href="/news/offbeat/">Offbeat</a></li> <li><a href="/news/politics/">Politics</a></li> <li><a href="/news/transport/">Transport</a></li> <li><a href="/news/your-say/">Your Say</a></li> <li><a href="/news/in-full/">In Full</a></li> <li><a href="http://edition.pagesuite-professional.co.uk/Launch.aspx?PBID=d376981d-732d-4761-8f60-3b1e2b067bfe" target="_blank">E-edition</a></li> </ul></div> </li> <li class="Parent nav-item dropdown"> <span><a href="/sport/" class="selected">Sport</a></span> <div class="menuChildren dropdown-menu-d"><ul> <li><a href="/sport/cricket/">Cricket</a></li> <li><a href="/sport/football/">Football</a></li> <li><a href="/sport/more-sport/">More Sport</a></li> <li><a href="/sport/in-full/">In Full</a></li> </ul></div> </li> <li class="Parent nav-item dropdown"> <span><a href="/lifestyle/">Lifestyle</a></span> </li> <li class="Parent nav-item dropdown"> <span><a href="/whats-on/">What's On</a></span> <div class="menuChildren dropdown-menu-d"><ul> <li><a href="/whats-on/arts/">Arts and Screen</a></li> <li><a href="/whats-on/music/">Music</a></li> <li><a href="/whats-on/theatre-and-comedy/">Theatre and Comedy</a></li> <li><a href="/whats-on/in-full/">In Full</a></li> </ul></div> </li> <li class="Parent nav-item dropdown"> <span><a href="https://www.imjobs.co.uk/" target="_blank">Jobs</a></span> </li> <li class="Parent nav-item dropdown"> <span><a href="/contact-us/">Contact</a></span> </li> <li class="Parent nav-item dropdown"> <span><a href="https://www.velvetmag.co.uk/" target="_blank">Velvet Mag</a></span> </li></ul> </div> </div> </div> <div class="col-auto p-2 pr-2"> <i class="fas fa-phone fa-flip-horizontal" style="font-size:0.75em; margin-right:3px;"></i> <a href="tel:01787-886908">01787 886 908</a> </div> <div class="col-auto float-right text-right p-2 text-center LoginBtn account"><div> <a href="/_api/transfer/transfer/login" rel="nofollow"> <span class="LoginFirst">Sign in&nbsp;&nbsp;</span><span class="usericon"><i class="fas fa-user-circle"></i></span> </a> </div></div> </div> </div> </div> </div> </header><div id="headerSpacer"></div> <div id="EwrapHead"></div> <div id="EWrap"> <div class="MainSite"> <div class="container white"> <div class="leaderboard text-center"> <div class="leader"><span id="ad_Head-Leader" class="advert" data-provider="3" data-devices="d" data-format="['billboard',970,1], ['lb1',728,90]"></span></div> <div class="banner"><span id="ad_Head-Banner" class="advert" data-provider="3" data-devices="t" data-format="['bannertablet',468,60]"></span></div> <div class="mobile"><span id="ad_Head-Mobile" class="advert" data-provider="3" data-devices="m" data-format="['bannermobile',320,50]"></span></div> <div class="Bread text-center pt-4 pb-3"><p> <a href="/" class="first"><i class="fa fa-home icon-2x"></i> Home</a> <i class="fa fa-angle-right"></i>&nbsp; <a href="/sport/">Sport</a> <i class="fa fa-angle-right"></i>&nbsp; Article</p></div> </div> </div><div class="container white"> <div class="row"> <div class="col-lg-8 ArticleInner"> <article><h1 class="HeadingFont">Nathan Blackmore comes out on top in Cycle Club Sudbury's Len Finch Memorial race</h1> <hr/> <div class="row"> <div class="col-12 col-md-10 col-lg-10"> <div class="authorName"><i class="fas fa-user-circle"></i> <span>By</span> Sport Sudbury <div class="authorEmail mb-1"> <div class="divide">-</div> <a href="mailto:sport@suffolkfreepress.co.uk">sport@suffolkfreepress.co.uk</a></div> </div> <div class="clearfixNone"></div> <div class="ArticleDate"><strong><i class="far fa-clock"></i> Published:</strong> 11:03, 24 August 2019 </div> </div> <div class="col-12 col-md-2 col-lg-2"> </div> </div> <hr/> <div class="row no-gutters SocialArticleIcons"> <div class="col twitter"><a href="javascript:void(0);" class="share twitter"><i class="fab fa-twitter-square"></i></a></div> <div class="col facebook"><a href="javascript:void(0);" class="share facebook"><i class="fab fa-facebook-square"></i></a></div> <div class="col google-plus"><a href="javascript:void(0);" class="share googleplus"><i class="fab fa-google-plus-square"></i></a></div> <div class="col pinterest"><a href="javascript:void(0);" class="share pinterest"><i class="fab fa-pinterest-square"></i></a></div> <div class="col linkedin"><a href="javascript:void(0);" class="share linkedin"><i class="fab fa-linkedin"></i></a></div> <div class="col reddit"><a href="javascript:void(0);" class="share reddit"><i class="fab fa-reddit-square"></i></a></div> <div class="col emails"><a href="javascript:void(0);" class="share email"><i class="fas fa-envelope"></i></a></div> </div> <hr/> <div class="pagestory"> <p>Nathan Blackmore survived a last lap crash on the Bulmer course on Sunday to take Eastern Road Race League honours by nine seconds, <i>writes Ken Watkins</i>.</p><p>The Flamme Rouge Cycling Team rider was in the lead at the time of the crash, during a spell of rain, but battled back after remounting to hold off the challenge from Felix Barker (Active Edge Race Team).</p><p>Blackmore completed the 52.4 miles in the Cycle Club Sudbury Len Finch Memorial race in one hour, 58 minutes and eight seconds.</p><figure><img class="rthmb" src="/1x1.gif" alt="Action from the Cycle Club Sudbury Len Finch Memorial race on Sunday Pictures: Mecha Morton" data-root="/_media/img/" data-path="9G18RXSH4Q60QEKVVZTT.jpg" data-ar="1.50"/><noscript><img src="/_media/img/9G18RXSH4Q60QEKVVZTT.jpg" alt="Action from the Cycle Club Sudbury Len Finch Memorial race on Sunday Pictures: Mecha Morton"/></noscript><figcaption>Action from the Cycle Club Sudbury Len Finch Memorial race on Sunday Pictures: Mecha Morton</figcaption></figure><p>Charles Kennedy-Scott (Cycling Club Hackney) was third in a bunch sprint, five seconds adrift of Barker.</p><p>CC Sudbury rider Leon West was 26th in 1:58:49, with club mates Jose Vicente-Garcia 43rd in 1:28:14, having completed three laps, and James Newton 48th (no time recorded).</p><span id="ad_891040686" class="advert" data-provider="3" data-devices="t" data-format="['mpu1',300,250]"></span> <span id="ad_715114748" class="advert" data-provider="3" data-devices="m" data-format="['mpu1',300,250]"></span> <p>Fifty riders started, with only one not finishing.</p><p>In the women’s race, just four riders completed all four laps, having built up a big lead over the rest of the field, who were stopped after three laps.</p><p>“There were two distinct bunches in the women’s race,” said CC Sudbury organiser Darren Rule, “and the gap was growing, so the commissaires made the call that the second group was losing contention, and stopped them after three laps.</p><span id="ad_133197200" class="advert" data-provider="3" data-devices="dt" data-format="['mpu2',300,250]"></span> <span id="ad_992610459" class="advert" data-provider="3" data-devices="m" data-format="['mpu2',300,250]"></span> <p>“So some got 37 miles instead of 50, but they still got the chequered flag, and some of them were placed.”</p><p>Francesca Hall (DAP Cycling Club) just held off the challenge of Nicole Oh (Les Filles Racing Team).</p><p>Both recorded times of two hours, 24 minutes and 26 seconds, Oh finishing 0.08 seconds adrift.</p><p>Gemma Melton (Pedal Power Cycles Ipswich) was one second behind, and Polly Mason (DAP) seven seconds further back.</p><span id="ad_120483008" class="advert" data-provider="3" data-devices="t" data-format="['mpu3',300,250]"></span> <span id="ad_585542509" class="advert" data-provider="3" data-devices="m" data-format="['mpu3',300,250]"></span> <figure><img class="rthmb" src="/1x1.gif" alt="Action from the Cycle Club Sudbury Len Finch Memorial race on Sunday Pictures: Mecha Morton" data-root="/_media/img/" data-path="FQTVV3HGTZZ708GF0GX7.jpg" data-ar="1.50"/><noscript><img src="/_media/img/FQTVV3HGTZZ708GF0GX7.jpg" alt="Action from the Cycle Club Sudbury Len Finch Memorial race on Sunday Pictures: Mecha Morton"/></noscript><figcaption>Action from the Cycle Club Sudbury Len Finch Memorial race on Sunday Pictures: Mecha Morton</figcaption></figure><p>Organiser Rule was pleased with the turnout of 23 riders in the women’s race.</p><p>“We didn’t have a women’s race last year as it would have clashed with the regionals,” he said.</p><p>“There are not as many women road racers, so this was a good turnout. Restricting entries to Class 2/3/4 may have limited numbers, but hopefully next year there will be more.”</p><p>The races were sponsored by Eisberg Alcohol-free Wines, and Newton Brickworks.</p><figure><img class="rthmb" src="/1x1.gif" alt="Action from the Cycle Club Sudbury Len Finch Memorial race on Sunday Pictures: Mecha Morton" data-root="/_media/img/" data-path="1G5350485VQ19L5TYH7Z.jpg" data-ar="1.50"/><noscript><img src="/_media/img/1G5350485VQ19L5TYH7Z.jpg" alt="Action from the Cycle Club Sudbury Len Finch Memorial race on Sunday Pictures: Mecha Morton"/></noscript><figcaption>Action from the Cycle Club Sudbury Len Finch Memorial race on Sunday Pictures: Mecha Morton</figcaption></figure><p>2019 Cycle Club Sudbury Len Finch Memorial race results: Men: 1 Nathan Blackmore Flamme Rouge Cycling Team, 2 Felix Barker ActiveEdge Race Team, 3 Charles Kennedy-Scott Cycling Club Hackney, 4 Neil Pearson Gemini BC, 5 Matthias Barnet Cycle Team OnForm, 6 Matthew Carter Velo Schils – Interbike RT, 7 Jake Towler Strada-Sport, 8 Robert Staines Pedal Power Cycles Ipswich, 9 Charles Jones DAP Cycling Club, 10 Billy Fadden Flamme Rouge Cycling Team, 11 Matthew Humpage Flamme Rouge Cycling Team, 12 Oliver Wood Strada-Sport, 13 James Street Team LDN, 14 Stephen Fuller Cambridge CC, 15 William Drury Pro Cycle Hire UK Racing Team, 16 Ian Perry Velo Schils – Interbike RT, 17 Stephen Messenger East London Velo, 18 Seb Herrod Strada-Sport, 19 James Sherwood Orwell Velo, 20 Douglas Allen Velo Schils – Interbike RT. Women: 1 Francesca Hall DAP Cycling Club, 2 Nicole Oh Les Filles Racing Team, 3 Gemma Melton Pedal Power Cycles Ipswich, 4 Polly Mason DAP Cycling Club, 5 Anna Marie Hughes 1904 RT, 6 Donna Dale Walden Velo, 7 Helen Bridgeman 1904 RT, 8 Michelle Arthurs-Brennan 1904 RT, 9 Caroline Humphries, 10 Sophie Holmes Datalynx-Parenesis Cycling, 11 Miriam Bullock East London Velo, 12 Nicola Lynch Newmarket Cycling &Triathlon Club, 13 Ruth Stapleton ST Neots CC, 14 Isabella Torrie Liv Awol, 15 Jenni Lake Lovelo Squadra Donne.</p><span id="ad_131005584" class="advert" data-provider="3" data-devices="d" data-format="['mpu3',300,250]"></span> <span id="ad_341765840" class="advert" data-provider="3" data-devices="t" data-format="['mpu4',300,250]"></span> <span id="ad_141479996" class="advert" data-provider="3" data-devices="m" data-format="['mpu4',300,250]"></span> </div> <div class="BottomShare"> <hr/> <div class="row no-gutters SocialArticleIcons"> <div class="col twitter"><a href="javascript:void(0);" class="share twitter"><i class="fab fa-twitter-square"></i></a></div> <div class="col facebook"><a href="javascript:void(0);" class="share facebook"><i class="fab fa-facebook-square"></i></a></div> <div class="col google-plus"><a href="javascript:void(0);" class="share googleplus"><i class="fab fa-google-plus-square"></i></a></div> <div class="col pinterest"><a href="javascript:void(0);" class="share pinterest"><i class="fab fa-pinterest-square"></i></a></div> <div class="col linkedin"><a href="javascript:void(0);" class="share linkedin"><i class="fab fa-linkedin"></i></a></div> <div class="col reddit"><a href="javascript:void(0);" class="share reddit"><i class="fab fa-reddit-square"></i></a></div> <div class="col emails"><a href="javascript:void(0);" class="share email"><i class="fas fa-envelope"></i></a></div> </div> <hr/> </div> <div id="TaboolaMain"> <div id="taboola-below-article-thumbnails"></div> <div id="taboola-below-article-thumbnails-mobile"></div> </div> <div class="clearfix"></div> <script type="text/javascript">$(document).ready(function(){siteResponsive.plugins.setTargetValue("articleid","373094")});</script></article> </div> <div class="col-12 col-md-12 col-lg-4 sidebar"> <aside><div class="d-none d-sm-none d-lg-block d-md-block"> <div class="MPU mb-3 text-center"><span id="ad_MPU1" class="advert" data-provider="3" data-devices="d" data-format="['mpu1',300,250]"></span></div><div class="titleline_color mb-3"> <h3 class="title_color">MOST READ</h3> </div> <div class="clearfix"></div> <div class="fetchPanel" data-url="/Panels/Most-Read/"></div><div class="origami mb-3"> <div id="origami-ad-container"></div> <script id="origami-ad-widget" src="https://origami.secure.ownlocal.com/origami-widget.js" data-partner-id="40fa825d-35d9-4504-bfc6-4809ad3c7177"></script> </div></div> <div class=" d-none d-sm-none d-md-block d-lg-block"> <div class="MPU mb-3"><span id="ad_MPU4" class="advert" data-provider="3" data-devices="d" data-format="['mpu4',300,250]"></span></div> <div class="TaboolaSide mb-3 p-4 text-center"> <div id="taboola-right-rail-thumbnails"></div> </div> </div> <div class="d-none d-md-block d-lg-block"><script src="//get.s-onetag.com/4357d25f-0b90-40b5-b8ec-b61b66b8ab43/tag.min.js" async="" defer=""></script></div></aside> </div> <div class="clearfix"></div> <div class="row"> <div class="col-12 col-sm-12 col-md-12 col-lg-12"><span id="ad_Teads" class="advert" data-provider="3" data-devices="dt" data-format="['teads',2,1]"></span><span id="ad_Teads-Mobile" class="advert" data-provider="3" data-devices="m" data-format="['teads',2,1]"></span></div> </div> </div> </div></div><footer> <div class="container"> <div class="row"> <div class="col-12 col-sm-6 col-lg-3"> <a href="http://iliffemedia.co.uk" target="_blank"> <img src="/_assets/iliffe_media_logo.png" class="img-fluid" alt="Iliffe Media Logo"/> </a> </div> <div class="col-12 col-sm-6 col-lg-9"> <div class="mt-3"> <a href="/rss-feeds/"><i class="fas fa-rss-square fa-2x" title="RSS"></i></a> <a href="https://en-gb.facebook.com/SuffolkFreePress/" target="_blank"><i class="fab fa-facebook fa-2x" title="Facebook"></i></a> <a href="https://twitter.com/SFPSudbury" target="_blank"><i class="fab fa-twitter-square fa-2x" title="Twitter"></i></a> </div> </div> </div> <div class="clearfix"></div> <hr class="custom"/> <div class="clearfix"></div> <div class="row"> <div class="col-6 col-sm-6 col-lg-3"> <ul class="pl-0"> <li><a href="http://iliffemedia.co.uk/about-us/" target="_blank">About</a> </li> <li><a href="/news">News</a> </li> <li><a href="/whats-on">What's On</a></li> </ul> </div> <div class="col-6 col-sm-6 col-lg-3"> <ul class="pl-0"> <li><a href="/advertise-with-us">Advertise</a></li> <li><a href="/contact-us">Contact</a></li> <li><a href="/lifestyle">Lifestyle</a></li> </ul> </div> <div class="col-6 col-sm-6 col-lg-3"> <ul class="pl-0"> <li><a href="/sport">Sport</a></li> <li class="fconsent"><a href="javascript:window.cmpConfig.methods.summon()">Consent Preferences (EU user only)</a></li> </ul> </div> <div class="col-6 col-sm-6 col-lg-3"> <a href="https://www.ipso.co.uk/" target="_blank"><img src="/_assets/ipso_regulated.jpg" class="img-fluid IPSOLogo" alt="IPSO Regulated Logo"/></a> </div> </div> <div class="clearfix"></div> <hr class="custom"/> <div class="clearfix"></div> <div class="row small"> <div class="col-md-6 col-lg-6 text-center text-lg-left">&#xA9;&nbsp;2019&nbsp;- Iliffe Media Publishing Ltd. All rights reserved.</div> <div class="col-md-6 col-lg-6 terms text-center text-lg-right"> <a href="http://iliffemedia.co.uk/terms-and-conditions/" target="_blank">Terms</a> - <a href="http://iliffemedia.co.uk/privacy-policy/" target="_blank">Privacy Policy</a> - <a href="/sitemap/">Sitemap</a> - <a href="/contact-us">Contact</a> </div> </div> </div> </footer><div id="clickSink"></div> <div id="cookiePopup"> <div class="container-fluid"> <div class="row"> <div class="col-9 col-md-10 col-lg-10"> <span class="cookietext"> This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies - <a class="learnmore" href="http://iliffemedia.co.uk/cookies-policy/" target="_blank">Learn More</a></span></div> <div class="col-3 col-md-2 col-lg-2 mt-2 mt-lg-0"> <a id="cookieClose" class="btn btn-secondary submit"> <i class="fas fa-check pr-1 pl-1"></i> AGREE</a> </div> </div> </div> </div><span id="ad_DHTML1" class="advert" data-provider="3" data-devices="dt" data-format="['dhtml1',1,1]"></span><span id="ad_DHTMLM1" class="advert" data-provider="3" data-devices="m" data-format="['dhtmlm1',1,1]"></span></div><script type="text/javascript">var elginConfig={map:{swLat:51.97817084245995,swLng:0.6277669926055296,neLat:52.10234484264812,neLng:0.8296407719024046}};</script> <div id="parsely-root" style="display: none"> <span id="parsely-cfg" data-parsely-site="suffolkfreepress.co.uk"></span> </div> <script>(function(k,g,a){var c=a.location.protocol,f=g+"-"+k,b=a.getElementById(f),j=a.getElementById(g+"-root"),l=c==="https:"?"d1z2jf7jlzjs58.cloudfront.net":"static."+g+".com";if(b){return}b=a.createElement(k);b.id=f;b.async=true;b.src=c+"//"+l+"/p.js";j.appendChild(b)})("script","parsely",document);</script>
    <script type="text/javascript">
      var ATTag = new ATInternet.Tracker.Tag();
      ATTag.page.set({ name: 'SP.Sport.NathanBlackmorecomesoutontopinCycleClubSudburysLenFinchMemorialrace', level2: '1', chapter1: 'Sport' });
      ATTag.dispatch();
    </script>
  </body>
</html>
